Rode mic help

Im hoping i can get some help here. I purchased the Rode micpod usb mic. Rode states its plug & play. You can plug the usb directly into your computer without the use of audio interface. I did this and there is so much static whete its completely drowning out my voice. I have tried everything from using different usb cables to tryung different usb ports to updating software and yes making sure my computer detects the mic and I’ve had zero success. This is frustrating as ive had to push all my interviews out a week until i can get this fixed. Does anyone have any recommendations? Do i in fact need an audio interface? Despite what Rode claims?

Any help is much appreciated
Paul

Is that this mic…

With a USB-C jack on the mic body.

Are you going into a USB-C jack on your mac? …or using a USB cable that has USB-C on one end, and the more common/larger USB on the computer side?

.yes thats it. And i tried it both types of cables.

Mac or PC? @TwinFlicks

PC. I use a asus tuff gaming laptop

1 Like

I know Mac’s better. Have you used another mic on this laptop successfully? Ie have you been able to connect a different usb mic without static?

Yes. Ive used 2 different Yeti mics previously with no issues.

1 Like

Im wondering if I do need an external audio interface even though Rode says I dont? Attached a screenshot of what Rode says

If nothing has changed on your laptop then it suggests that part of the chain is OK and it may be the Rode Podmic end. If you have access to another laptop you can plug the rode into it would confirm this for you - however, I know this is less likely.

Sorry another set of random questions trying to understand the position you are in:

  • Where did you buy it?

  • Do you have an audio interface you could connect the mic to via XLR? just to confirm the mic capsule is OK and was not damaged in transit.

  • Is your voice not coming through at all - just static?

  • Is the volume setting somewhere between 50% and 75%?

  • Are you testing it in some software? eg a game, or zoom, or Audacity?

I have a PC I can try it on.

I purchased from Best Buy
I dont have an interface
I tried it on zoom and i tried with Rode’s aoftware and it does the samething
You can hear my voice but very faint
Yes volume is set

1 Like

That would be worth trying - to narrow down the things that could be the cause.

Their technical knowledge is likely to be limited but if you have evidence it is faulty, they should replace/refund. You can ask Rode for support but by email during office hours in Australia. Doing some searches, some people seem to be having a similar problem, but I am not sure it is a Rode problem in general.

When it is plugged in, can you hear if you do a gentle tap on the mic?
How are you listening? Headphones or speakers, or inbuilt laptop speakers?

I just spoke with Rode’s tech support. The mic is plug and play with the USBC and after testing he came to the conclusion the mic is bad. He said there is no reason for there to just be static. So it must be a faulty microphone. Im going to bring it into Best Buy and exchange it for new one. And hopefully that is in fact the issue.

1 Like

Excellent - I hope it is the simple solution you need. Let us know how you get on. Steve